Installation documentation on Windows

This documentation only applies for Netzob 0.3.3.

Installation of dependencies

  1. Install Python 2.7 (download the installer from
  2. Install SetupTools (download the installer from
  3. Install PyGTK (download the installer from
  4. Install WinPCap 4.1.3 (download the installer from
  5. Install Matplotlib 1.2.1 for (download the installer from
  6. Install Pcapy 0.10.8 (provided on Netzob's website ; original source:
  7. Install following dependencies with SetupTools (be sure to have C:\Python27\Scripts\easy_install.exe in your PATH):
    1. easy_install numpy
    2. easy_install impacket
    3. easy_install lxml
    4. easy_install bitarray==0.3.5

Installation of Netzob

  1. Install Netzob !

Remark: If you have disabled Windows UAC, a error can be raised by Windows when executing Netzob's installer: Failed to start elevated process (ShellExecute returned 3). So you have to run the installer with administrator privilege : right-click on the executable and choose "run as administrator".

Also available in: PDF HTML TXT